| FazBrowse GitHub Viewer | Trending | | Home |
| Tools: [Download Repo ZIP] [Original HTTPS Page] |
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -83,15 +83,15 @@ | |||
| 83 | 83 | </p> | |
| 84 | 84 | <ul> | |
| 85 | 85 | <li>Holders of <a href="https://www.cryptoworkshop.com">Crypto Workshop Support Contracts</a>. Without the consulting time left over from support contracts being contributed back to working on the Bouncy Castle APIs, progress would be impossible. You know who you are!</li> | |
| 86 | - <li><a href="http://www.atlassian.com/">Atlassian Software Systems</a> donation of Confluence and JIRA licences.</li> | ||
| 87 | - <li><a href="http://www.grierforensics.com/">Grier Forensics</a>, for collaborating in the development of the S/MIME Toolkit and DANE SMIMEA functionality.</li> | ||
| 86 | + <li><a href="https://www.atlassian.com/">Atlassian Software Systems</a> donation of Confluence and JIRA licences.</li> | ||
| 87 | + <li><a href="https://www.grierforensics.com/">Grier Forensics</a>, for collaborating in the development of the S/MIME Toolkit and DANE SMIMEA functionality.</li> | ||
| 88 | 88 | <li>TU-Darmstadt, Computer Science Department, RBG, for the initial | |
| 89 | 89 | lightweight client side TLS implementation, which is based on MicroTLS and for help with qTESLA implementation. MicroTLS was developed by Erik Tews under the supervision of Dipl.-Ing. Henning Baer and Prof. Max Muehlhaeuser. qTESLA assistance was provided by Nina Bindel and Yinhua Xu. | |
| 90 | 90 | </li> | |
| 91 | 91 | <li>TU-Darmstadt, Computer Science Department, RBG, for the initial | |
| 92 | 92 | Post Quantum provider, which was based on the FlexiProvider. The FlexiProvider was developed | |
| 93 | 93 | by the Theoretical Computer Science Research Group at TU-Darmstadt, Computer Science Department, RBG under the supervision of Prof. Dr. Johannes Buchmann. More information on the history of FlexiProvider can be found at: | |
| 94 | - <a href="http://www.flexiprovider.de/">http://www.flexiprovider.de/</a> | ||
| 94 | + <a href="https://www.flexiprovider.de/">https://www.flexiprovider.de/</a> | ||
| 95 | 95 | </li> | |
| 96 | 96 | <li>Voxeo Labs - sponsorship of the initial development of APIs for DTLS 1.0 (RFC 4347), DTLS-SRTP key negotiation (RFC 5764), | |
| 97 | 97 | and server side TLS 1.1 (RFC 4346) and tested WebRTC compatibility. More information on Voxeo Labs can be found at <a href="http://voxeolabs.com">http://voxeolabs.com</a></li> | |
@@ -251,7 +251,7 @@ | |||
| 251 | 251 | <li>Albert Moliner <amoliner@evintia.com> - initial TSP implementation.</li> | |
| 252 | 252 | <li>Carlos Lozano <carlos@evintia.com> - initial TSP implementation, patch to SignerInformation for supporting repeated signers, initial updates for supporting repeated attributes in CMS.</li> | |
| 253 | 253 | <li>Javier Delgadillo <javi@javi.codewarp.org> - initial Mozilla PublicKeyAndChallenge classes.</li> | |
| 254 | - <li>Joni Hahkala <joni.hahkala@cern.ch> - initial implementations of VOMS Attribute Certificate Validation, IetfAttrSyntax, and ObjectDigestInfo. We also wish to thank the <a href="http://www.eu-egee.org">EGEE project</a> for making the work available.</li> | ||
| 254 | + <li>Joni Hahkala <joni.hahkala@cern.ch> - initial implementations of VOMS Attribute Certificate Validation, IetfAttrSyntax, and ObjectDigestInfo. We also wish to thank the <a href="https://www.eu-egee.org">EGEE project</a> for making the work available.</li> | ||
| 255 | 255 | <li>Rolf Schillinger<rolf@sir-wum.de> - initial implementation of Attribute Certificate generation.</li> | |
| 256 | 256 | <li>Sergey Bahtin <Sergey_Bahtin@yahoo.com> - fix for recovering certificate aliases in BKS and UBER key stores. Initial implementations of GOST-28147, GOST-3410, EC GOST-3410, GOST OFB mode (GOFB) and GOST-3411.</li> | |
| 257 | 257 | <li>Franck Leroy <Franck.Leroy@keynectis.com> - ANS.1 set sorting. Contributions to TSP implementation. Test vectors for Bleichenbacher's forgery attack.</li> | |
@@ -286,7 +286,7 @@ | |||
| 286 | 286 | <li>Kishimoto Kazuhiko <kazu-k@hi-ho.ne.jp> - RFC 3280 updates to policy processing in the CertPath validator. Additional test data not covered by NIST.</li> | |
| 287 | 287 | <li>Lawrence Tan <lwrnctan@gmail.com> - Large field OID sample test data. Missing key types in JDKKeyFactory.</li> | |
| 288 | 288 | <li>Carlos Valiente <superdupont@gmail.com> - Addition of CRL writing to the PEMWriter class.</li> | |
| 289 | - <li>Keyon AG, Martin Christinat, <a href="http://www.keyon.ch">http://www.keyon.ch</a> - fixing incorrect | ||
| 289 | + <li>Keyon AG, Martin Christinat, <a href="https://www.keyon.ch">https://www.keyon.ch</a> - fixing incorrect | ||
| 290 | 290 | ASN.1 encoding of field elements in X9FieldElement class.</li> | |
| 291 | 291 | <li>Olaf Keller, <olaf.keller.bc@bluewin.ch> - initial implementation of the elliptic curves over binary fields F2m. Additional tests and modifications to elliptic curve support for both F2m and Fp. Performance improvements to F2m multiplication. Initial implementation of WNAF/WTNAF point multiplication. Improvement to k value generation in ECDSA.</li> | |
| 292 | 292 | <li>Jörg Eichhorn <eichhorn@ponton-consulting.de> - patch to fix EOF read on SharedFileInputStream, support for F2m compression.</li> | |
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -8,7 +8,7 @@ The Legion also gratefully acknowledges the contributions made to this package b | |||
| 8 | 8 | ||
| 9 | 9 | The package is organised so that it contains a light-weight API suitable for use in any environment (including the newly released J2ME) with the additional infrastructure to conform the algorithms to the JCE framework. | |
| 10 | 10 | ||
| 11 | - Except where otherwise stated, this software is distributed under a license based on the MIT X Consortium license. To view the license, [see here](https://www.bouncycastle.org/licence.html). The OpenPGP library also includes a modified BZIP2 library which is licensed under the [Apache Software License, Version 2.0](http://www.apache.org/licenses/). | ||
| 11 | + Except where otherwise stated, this software is distributed under a license based on the MIT X Consortium license. To view the license, [see here](https://www.bouncycastle.org/licence.html). The OpenPGP library also includes a modified BZIP2 library which is licensed under the [Apache Software License, Version 2.0](https://www.apache.org/licenses/). | ||
| 12 | 12 | ||
| 13 | 13 | **Note**: this source tree is not the FIPS version of the APIs - if you are interested in our FIPS version please contact us directly at [office@bouncycastle.org](mailto:office@bouncycastle.org). | |
| 14 | 14 | ||
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -5,7 +5,7 @@ | |||
| 5 | 5 | /** | |
| 6 | 6 | * German Federal Office for Information Security | |
| 7 | 7 | * (Bundesamt für Sicherheit in der Informationstechnik) | |
| 8 | - * <a href="http://www.bsi.bund.de/">http://www.bsi.bund.de/</a> | ||
| 8 | + * <a href="https://www.bsi.bund.de/">https://www.bsi.bund.de/</a> | ||
| 9 | 9 | * <p> | |
| 10 | 10 | * <a href="https://www.bsi.bund.de/EN/Publications/TechnicalGuidelines/TR03110/BSITR03110.html">BSI TR-03110</a> | |
| 11 | 11 | * Technical Guideline Advanced Security Mechanisms for Machine Readable Travel Documents | |
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -67,8 +67,8 @@ | |||
| 67 | 67 | * component namingAuthorityId are grouped under the OID-branch | |
| 68 | 68 | * id-isis-at-namingAuthorities and must be applied for. | |
| 69 | 69 | * <li>See | |
| 70 | - * http://www.teletrust.de/anwend.asp?Id=30200&Sprache=E_&HomePG=0 for | ||
| 71 | - * an application form and http://www.teletrust.de/links.asp?id=30220,11 | ||
| 70 | + * https://www.teletrust.de/anwend.asp?Id=30200&Sprache=E_&HomePG=0 for | ||
| 71 | + * an application form and https://www.teletrust.de/links.asp?id=30220,11 | ||
| 72 | 72 | * for an overview of registered naming authorities. | |
| 73 | 73 | * <li> By means of the data type ProfessionInfo certain professions, | |
| 74 | 74 | * specializations, disciplines, fields of activity, etc. are identified. A | |
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -15,7 +15,7 @@ | |||
| 15 | 15 | ||
| 16 | 16 | /** | |
| 17 | 17 | * Elliptic curves defined in "ECC Brainpool Standard Curves and Curve Generation" | |
| 18 | - * http://www.ecc-brainpool.org/download/draft_pkix_additional_ecc_dp.txt | ||
| 18 | + * https://www.ecc-brainpool.org/download/draft_pkix_additional_ecc_dp.txt | ||
| 19 | 19 | */ | |
| 20 | 20 | public class TeleTrusTNamedCurves | |
| 21 | 21 | { | |
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -123,12 +123,12 @@ public class KeyPurposeId | |||
| 123 | 123 | ||
| 124 | 124 | ||
| 125 | 125 | /** | |
| 126 | - * Microsoft Server Gated Crypto (msSGC) see http://www.alvestrand.no/objectid/1.3.6.1.4.1.311.10.3.3.html | ||
| 126 | + * Microsoft Server Gated Crypto (msSGC) see https://www.alvestrand.no/objectid/1.3.6.1.4.1.311.10.3.3.html | ||
| 127 | 127 | */ | |
| 128 | 128 | public static final KeyPurposeId id_kp_msSGC = new KeyPurposeId(new ASN1ObjectIdentifier("1.3.6.1.4.1.311.10.3.3")); | |
| 129 | 129 | ||
| 130 | 130 | /** | |
| 131 | - * Netscape Server Gated Crypto (nsSGC) see http://www.alvestrand.no/objectid/2.16.840.1.113730.4.1.html | ||
| 131 | + * Netscape Server Gated Crypto (nsSGC) see https://www.alvestrand.no/objectid/2.16.840.1.113730.4.1.html | ||
| 132 | 132 | */ | |
| 133 | 133 | public static final KeyPurposeId id_kp_nsSGC = new KeyPurposeId(new ASN1ObjectIdentifier("2.16.840.1.113730.4.1")); | |
| 134 | 134 | ||
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -18,7 +18,7 @@ | |||
| 18 | 18 | * subjectDomainPolicy CertPolicyId } | |
| 19 | 19 | * </pre> | |
| 20 | 20 | * | |
| 21 | - * @see <a href="http://www.faqs.org/rfc/rfc3280.txt">RFC 3280, section 4.2.1.6</a> | ||
| 21 | + * @see <a href="https://www.faqs.org/rfc/rfc3280.txt">RFC 3280, section 4.2.1.6</a> | ||
| 22 | 22 | */ | |
| 23 | 23 | public class PolicyMappings | |
| 24 | 24 | extends ASN1Object | |
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -5,7 +5,7 @@ | |||
| 5 | 5 | ||
| 6 | 6 | /** | |
| 7 | 7 | * implementation of RIPEMD see, | |
| 8 | - * http://www.esat.kuleuven.ac.be/~bosselae/ripemd160.html | ||
| 8 | + * https://www.esat.kuleuven.ac.be/~bosselae/ripemd160.html | ||
| 9 | 9 | */ | |
| 10 | 10 | public class RIPEMD160Digest | |
| 11 | 11 | extends GeneralDigest | |
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -5,8 +5,8 @@ | |||
| 5 | 5 | ||
| 6 | 6 | /** | |
| 7 | 7 | * implementation of Tiger based on: | |
| 8 | - * <a href="http://www.cs.technion.ac.il/~biham/Reports/Tiger"> | ||
| 9 | - * http://www.cs.technion.ac.il/~biham/Reports/Tiger</a> | ||
| 8 | + * <a href="https://www.cs.technion.ac.il/~biham/Reports/Tiger"> | ||
| 9 | + * https://www.cs.technion.ac.il/~biham/Reports/Tiger</a> | ||
| 10 | 10 | */ | |
| 11 | 11 | public class TigerDigest | |
| 12 | 12 | implements ExtendedDigest, Memoable | |
| Original file line number | Diff line number | Diff line change | |
|---|---|---|---|
@@ -3,7 +3,7 @@ | |||
| 3 | 3 | /** | |
| 4 | 4 | * An implementation of the Camellia key wrapper based on RFC 3657/RFC 3394. | |
| 5 | 5 | * <p> | |
| 6 | - * For further details see: <a href="http://www.ietf.org/rfc/rfc3657.txt">http://www.ietf.org/rfc/rfc3657.txt</a>. | ||
| 6 | + * For further details see: <a href="https://www.ietf.org/rfc/rfc3657.txt">https://www.ietf.org/rfc/rfc3657.txt</a>. | ||
| 7 | 7 | */ | |
| 8 | 8 | public class CamelliaWrapEngine | |
| 9 | 9 | extends RFC3394WrapEngine | |
| Back | FazBrowse Home | New Git URL |
0 commit comments