| FazBrowse Wikipedia Viewer | Main Page | | |
| Viewing: https://fr.wikipedia.org/wiki/Network_File_System |
| Contents |
|---|
| NFS versions 1, 2 et 3 |
| NFSv4.1 |
| NFSv4.2 |
| Liens externes |
Pour les articles homonymes, voir NFS.
| Fonction | Partage de fichiers |
|---|---|
| Sigle | NFS |
| Date de création | 1984 |
| Port | 2049 |
| RFC |
1989 : RFC 1094 1995 : RFC 1813 2003 : RFC 3530 2010 : RFC 5661 2016 : RFC 7862 |
Les versions 1 et 2 sont non sécurisées, prévues pour fonctionner sur UDP.
La version 3 est étendue pour prendre en charge TCP.
Dans ces versions, la gestion de la sécurité reste élémentaire et souffre d'importantes lacunes. Le système est sans état (statefull), non compatible avec les précédentes versions. De plus, NFSv4.2 n'est pas prévu pour pouvoir utiliser le protocole UDP, il ne peut fonctionner qu'avec le protocole TCP. NFSv4.0 et NFSv4.1 utilisent le protocole TCP par défaut, mais peuvent fonctionner avec UDP pour une compatibilité ascendante.
NFSv4 suppose l'utilisation d'UTF-8, pour les noms de fichiers, sans que ce soit obligatoire.
Pour toutes ces raisons il est hautement préférable d'utiliser NFSv4 plutôt que NFSv3, dans la mesure où une migration totale est possible.
La version 4.1 de NFS a été publiée dans le RFC 5661 en striping).
La version 4.2 de NFS a été publiée dans le RFC 7862 en
| View original on Wikipedia | Back | FazBrowse Home |