FazBrowse GitHub Viewer
|
Trending
|
URL:
|
Home
Tools:
[Download Repo ZIP]
[Original HTTPS Page]
ireader/media-server: RTSP/RTP/RTMP/FLV/HLS/MPEG-TS/MPEG-PS/MPEG-DASH/MP4/fMP4/MKV/WebM · GitHub
ireader
/
media-server
Public
Notifications
You must be signed in to change notification settings
Fork
1.2k
Star
3.5k
Code
Issues
102
Pull requests
6
Discussions
Actions
Projects
Wiki
Security and quality
5
Insights
Additional navigation options
Code
Issues
Pull requests
Discussions
Actions
Projects
Wiki
Security and quality
Insights
Branches
Tags
Open more actions menu
Latest commit
History
1,484 Commits
1,484 Commits
Folders and files
Name
Name
Last commit message
Last commit date
.github/
workflows
.github/
workflows
libdash
libdash
libflv
libflv
libhls
libhls
libmkv
libmkv
libmov
libmov
libmpeg
libmpeg
librtmp
librtmp
librtp
librtp
librtsp
librtsp
libsip
libsip
media-server.xcworkspace
media-server.xcworkspace
test
test
.gitignore
.gitignore
.travis.yml
.travis.yml
Android.mk
Android.mk
Application.mk
Application.mk
LICENSE
LICENSE
Makefile
Makefile
README.md
README.md
SECURITY.md
SECURITY.md
compile.cn.md
compile.cn.md
gcc.mk
gcc.mk
media-server.sln
media-server.sln
Repository files navigation
README
MIT license
Security
Build status:
Build Dependence:
https://github.com/ireader/sdk
libflv
FLV video codec: H.264/H.265/H.266/AV1/VP8/VP9/VP10
FLV audio codec: AAC/MP3/G.711/Opus
FLV file read/write
H.264/H.265/H.266/AV1 bitstream filter: annex-b <-> mp4 stream
AAC bitstream filter: ADTS <-> ASC
librtmp
rtmp-client: RTMP publish/play
rtmp-server: RTMP Server live/vod streaming
libmpeg
ITU-T H.222.0 PS/TS read/write
ps/ts codec: H.264/H.265/H.266/AAC/MP3/G.711/Opus
librtp
RFC3550 RTP/RTCP
RTP with H.264/H.265/H.266/MPEG-2/MPEG-4/VP8/VP9/AV1
RTP with G.711/G.726/G.729/MP3/AAC/Opus
RTP with MPEG-2 PS/TS
RTP Header Extension
RTCP PSFB/RTPFB/XR
librtsp
RFC2326 RTSP
RFC4566 SDP
SDP fmtp: H.264/H.265/H.266/AAC/Opus/G.711
libhls
HLS M3U8: generate m3u8 file
HLS Media: TS segmenter
HLS fmp4 segmenter
HLS Master/Playlist m3u8 parser
libdash
ISO/IEC 23009-1 MPEG-DASH static(vod)
ISO/IEC 23009-1 MPEG-DASH dynamic(live)
DASH MPD v3/v4 parser
libmov
ISO/IEC 14496-12 MP4 File reader/writer
MP4 faststart(moov box before mdat)
fMP4(Fragment MP4) writer
MP4 with H.264/H.265/H.266/AV1/VP8/VP9/JPEG/PNG
MP4 with AAC/Opus/MP3/G.711
libmkv
MKV/WebM file read/write
MKV/WebM live streaming
libsip
sip user-agent (UAC/UAS)
sip with ICE
libhttp(
https://github.com/ireader/sdk
)
HTTP Server(base AIO)
HTTP Client
HTTP Cookie
Make
make clean && make
make RELEASE=1 (make release library, default debug)
make PLATFORM=arm-hisiv100nptl-linux (cross compile)
编译说明
友情链接
ZLMediaKit
基于C++11的高性能运营级流媒体服务框架
MediaInsight360
流媒体格式在线解析
About
RTSP/RTP/RTMP/FLV/HLS/MPEG-TS/MPEG-PS/MPEG-DASH/MP4/fMP4/MKV/WebM
Topics
flv
fmp4
hls
m3u
m3u8
mkv
mp4
mpeg-dash
ps
rtmp
rtp
rtsp
sdp
sip
ts
webm
Resources
Readme
MIT license
Security policy
Security policy
Activity
Stars
3.5k
stars
Watchers
192
watching
Forks
1.2k
forks
Report repository
Releases
Packages
Used by
Contributors
Languages
Back
|
FazBrowse Home
|
New Git URL