FazBrowse Wikipedia Viewer | Main Page |
Search Wikipedia:
|
Viewing: https://en.wikipedia.org/wiki/Network_File_System

Network File System

Network File System (NFS) is a distributed file system protocol originally developed by Sun Microsystems (Sun) in 1984, allowing a user on a client computer to access files over a computer network much like local storage is accessed. NFS, like many other protocols, builds on the Open Network Computing Remote Procedure Call (ONC RPC) system. NFS is an open IETF standard. After the first experimental version developed in house at Sun Microsystems, all subsequent versions of the protocol are defined in a series of Request for Comments i.e. RFCs, allowing anyone to implement the protocol.

RFC 3530, April 2003 and again in RFC 8881, August 2020) aims to provide protocol support to take advantage of clustered server deployments including the ability to provide scalable parallel access to files distributed among multiple servers (pNFS extension). Version 4.1 includes Session trunking mechanism (Also known as NFS Multipathing) and is available in some enterprise solutions as VMware ESXi.

NFS version 4.2 (ISBN 0-201-32570-5

  • 1 2 Arpaci-Dusseau, Remzi; Arpaci-Dusseau, Andrea (March 2015). Operating Systems: Three Easy Pieces (PDF) (.9 ed.). Arpaci-Dusseau Books. p. 5. Archived (PDF) from the original on 3 April 2019. Retrieved 8 November 2017.
  • ↑ Brian Pawlowski; Spencer Shepler; Carl Beame; Brent Callaghan; Michael Eisler; David Noveck; David Robinson; Robert Thurlow (2000). "The NFS Version 4 Protocol" (PDF). SANE. Archived from the original (PDF) on 2025-02-02.
  • ↑ Tom Talpey (February 28, 2006). "NFS/RDMA Implementation(s) Update" (PDF). Network Appliance, Inc. Archived from the original (PDF) on May 12, 2011.
  • ↑ Glover, Fred (28 May 1994). "A Specification of Trusted NFS (TNFS) Protocol Extensions". datatracker.ietf.org.
  • ↑ "What is Connectathon?". Original Connectathon.Org web site. Archived from the original on January 28, 1999.
  • ↑ "Set up file sharing on Mac". Apple Support. Retrieved 7 August 2025.
  • ↑ "Other Software by SUN Microsystems". www.computinghistory.org.uk. The Centre for Computing History. Retrieved 24 September 2016.
  • ↑ "Networking related programs". cp15.org.
  • External links

    edit
    RFC 1014 – XDR: External Data Representation Standard (obsoleted by RFC 1832)
  • RFC 1813 – NFS Version 3 Protocol Specification
  • RFC 2055 – WebNFS Server Specification
  • RFC 2339 – Sun/ISOC NFS Change Control Agreement
  • RFC 4506 – XDR: External Data Representation Standard
  • RFC 5661 – NFS Version 4.1 Protocol Specification (obsoleted by RFC 8881)
  • RFC 5664 – Parallel NFS - Object-Based Operations Specification
  • RFC 5667 – NFS Direct Data Placement
  • RFC 7862 – NFS Version 4.2 Protocol Specification
  • RFC 8166 – Remote Direct Memory Access Transport for Remote Procedure Call Version 1 (updated by RFC 8797)
  • RFC 8276 – Xattrs extension for NFSv4
  • RFC 8881 – NFS Version 4.1 Protocol Specification
  • Sun Microsystems logo
  • Software
    Storage
    Performance
    Research
    Education
    Acquisitions
    Slogans
    Community
    People
    Category
    File systems
    Disk and
    non-rotating
    Optical disc
    Flash memory and SSD
    host-side wear leveling
    Distributed parallel
    NAS
    Specialized
    Pseudo
    Encrypted
    Types
    Features
    Access control
    Interfaces
    Lists
    Layouts
    National
    Other

    View original on Wikipedia | Back | FazBrowse Home