| Internet media type | U.S. patent 2,437,707. The three of them published "The Philosophy of PCM" in 1948.
The T-carrier system, introduced in 1961, uses two twisted-pair transmission lines to carry 24 PCM telephone calls sampled at 8 kHz and 8-bit resolution. This development improved capacity and call quality compared to the previous frequency-division multiplexing schemes.
In 1973, adaptive differential pulse-code modulation (ADPCM) was developed, by P. Cummiskey, Nikil Jayant and James L. Flanagan.
Digital audio recordingsedit
fs/2).
Standard sampling precision and ratesedit
Common sample depths for LPCM are 8, 16, 20 or 24 bits per sample.
LPCM encodes a single sound channel. Support for multichannel audio depends on file format and relies on synchronization of multiple LPCM streams. While two channels (stereo) is the most common format, systems can support up to 8 audio channels (7.1 surround) or more.
Common sampling frequencies are 48 kHz as used with DVD format videos, or 44.1 kHz as used in CDs. Sampling frequencies of 96 kHz or 192 kHz can be used on some equipment, but the benefits have been debated.
The Nyquist–Shannon sampling theorem shows PCM devices can operate without introducing distortions within their designed frequency bands if they provide a sampling frequency at least twice that of the highest frequency contained in the input signal. For example, in telephony, the usable voice frequency band ranges from approximately 300 to 3400 Hz. For effective reconstruction of the voice signal, telephony applications therefore typically use an 8000 Hz sampling frequency, which is more than twice the highest usable voice frequency.
Regardless, there are potential sources of impairment implicit in any PCM system:
- Choosing a discrete value that is near but not exactly at the analog signal level for each sample leads to quantization error. When dithering is used to compensate for this, it introduces additional noise.
- Between samples, no measurement of the signal is made; the sampling theorem guarantees non-ambiguous representation and recovery of the signal only if it has no energy at frequency fs/2 or higher (one half the sampling frequency, known as the Nyquist frequency); higher frequencies will not be correctly represented or recovered and add aliasing distortion to the signal below the Nyquist frequency.
- As samples are dependent on time, an accurate clock is required for accurate reproduction. If either the encoding or decoding clock is not stable, these imperfections will directly affect the output quality of the device.
Processing and codingedit
Some forms of PCM combine signal processing with coding. Older versions of these systems applied the processing in the analog domain as part of the analog-to-digital process; newer implementations do so in the digital domain. These simple techniques have been largely rendered obsolete by modern transform-based audio compression techniques, such as modified discrete cosine transform (MDCT) coding.
- Linear PCM (LPCM) is PCM with linear quantization.
- Differential PCM (DPCM) encodes the PCM values as differences between the current and the predicted value. An algorithm predicts the next sample based on the previous samples, and the encoder stores only the difference between this prediction and the actual value. If the prediction is reasonable, fewer bits can be used to represent the same information. For audio, this type of encoding reduces the number of bits required per sample by about 25% compared to PCM.
- Adaptive differential pulse-code modulation (ADPCM) is a variant of DPCM that varies the size of the quantization step to allow further reduction of the required bandwidth for a given signal-to-noise ratio.
- Delta modulation is a form of DPCM that uses one bit per sample to indicate whether the signal is increasing or decreasing compared to the previous sample.
In telephony, a standard audio signal for a single phone call is encoded as 8,000 samples per second, of 8 bits each, giving a 64 kbit/s digital signal known as DS0. The default signal compression encoding on a DS0 is either μ-law (mu-law) PCM (North America and Japan) or A-law PCM (Europe and most of the rest of the world). These are logarithmic compression systems where a 12- or 13-bit linear PCM sample number is mapped into an 8-bit value. This system is described by international standard G.711.
Where circuit costs are high and loss of voice quality is acceptable, it sometimes makes sense to compress the voice signal even further. An ADPCM algorithm is used to map a series of 8-bit μ-law or A-law PCM samples into a series of 4-bit ADPCM samples. In this way, the capacity of the line is doubled. The technique is detailed in the G.726 standard.
Audio coding formats and audio codecs have been developed to achieve further compression. Some of these techniques have been standardized and patented. Advanced compression techniques, such as modified discrete cosine transform (MDCT) and linear predictive coding (LPC), are now widely used in mobile phones, voice over IP (VoIP) and streaming media.
Encoding for serial transmissionedit
- ↑ Among the first recordings was Uzu: The World Of Stomu Yamash'ta 2 by Stomu Yamashta.
- ↑ The first recording with this new system was recorded in Tokyo during April 24–26, 1972.
- ↑ Other methods exist such as pulse-density modulation used also on Super Audio CD.
- ↑ Some systems use digital filtering to remove some of the aliasing, converting the signal from digital to analog at a higher sample rate such that the analog anti-aliasing filter is much simpler. In some systems, no explicit filtering is done at all; as it is impossible for any system to reproduce a signal with infinite bandwidth, inherent losses in the system compensate for the artifacts — or the system simply does not require much precision.
- ↑ Quantization error swings between -q/2 and q/2. In the ideal case (with a fully linear ADC and signal level >> q) it is uniformly distributed over this interval, with zero mean and variance of q/12.
- ↑ A slight difference between the encoding and decoding clock frequencies is not generally a major concern; a small constant error is not noticeable. Clock error does become a major issue if the clock contains significant jitter, however.
- 1 2 3 Alvestrand, Harald Tveit; Salsman, James (May 1999). "RFC 2586 – The Audio/L16 MIME content type". IETF. The Internet Society. doi:10.17487/RFC2586. Retrieved March 16, 2010.
- 1 2 3 "Audio Media Types". IETF. Internet Assigned Numbers Authority. Retrieved March 16, 2010.
- 1 2 3 4 Leibson, Steven (September 7, 2021). "A Brief History of the Single-Chip DSP, Part I". EEJournal. Retrieved September 19, 2024.
- ↑ "The Bartlane Transmission System". DigicamHistory.com. Archived from the original on February 10, 2010. Retrieved January 7, 2010.
- ↑ U.S. patent number 1,608,527; also see p. 8, Data conversion handbook, Walter Allan Kester, ed., Newnes, 2005, Porter, Arthur (2004). So Many Hills to Climb. Beckham Publications Group. ISBN 9780931761188.Goodall, W. M. (January 1951). "Television by Pulse Code Modulation". Bell System Technical Journal. 30. Bell Labs: 33–49. Bibcode:1951BSTJ...30...33G. doi:10.1002/j.1538-7305.1951.tb01365.x. Retrieved May 14, 2017.
- ↑
Thomas Fine (2008). "The dawn of commercial digital recording" (PDF). ARSC Journal. 39 (1): 1–17.
- ↑ Allstot, David J. (2016). "Switched Capacitor Filters" ( (PDF)). In Maloberti, Franco; Davies, Anthony C. (eds.). A Short History of Circuits and Systems: From Green, Mobile, Pervasive Networking to Big Data Computing. IEEE Circuits and Systems Society. pp. 105–110. ISBN 9788793609860. Archived from the original on September 30, 2021. Retrieved November 29, 2019.
- 1 2 3 Blu-ray Disc Association (March 2005), White paper Blu-ray Disc Format – 2.B Audio Visual Application Format Specifications for BD-ROM (PDF), retrieved July 26, 2009
- ↑ "How DV works". Digital Voice Recording. Archived from the original on December 6, 2007. Retrieved March 21, 2010.
- ↑ Mostafa, Mohamed; Kumar, Rajesh (May 2001). "RFC 3108 – Conventions for the use of the Session Description Protocol (SDP) for ATM Bearer Connections". IETF. doi:10.17487/RFC3108. Retrieved March 16, 2010.
- ↑ https://www.its.bldrdoc.gov/fs-1037/dir-039/_5829.htm
- ↑ Stallings, William, Digital Signaling Techniques, December 1984, Vol. 22, No. 12, IEEE Communications Magazine
filed in 1943: N-ary Pulse Code Modulation.
Information about PCM: A description of PCM with links to information about subtypes of this format (for example linear pulse-code modulation), and references to their specifications.
Summary of LPCM – Contains links to information about implementations and their specifications.
How to control internal/external hardware using Microsoft's Media Control Interface – Contains information about, and specifications for the implementation of LPCM used in WAV files.
RFC 4856 – Media Type Registration of Payload Formats in the RTP Profile for Audio and Video Conferences – audio/L8 and audio/L16 (March 2007)
RFC 3190 – RTP Payload Format for 12-bit DAT Audio and 20- and 24-bit Linear Sampled Audio (January 2002)
RFC 3551 – RTP Profile for Audio and Video Conferences with Minimal Control – L8 and L16 (July 2003)
High-definition (HD) |
|---|