- {{Cite web|url=https://www.iana.org/assignments/arp-parameters/arp-parameters.xhtml|title=Address Resolution Protocol (ARP) Parameters|website=www.iana.org|access-date=2018-10-16}}</ref> In this example, a value of {{Mono|1}} indicates [[Ethernet]]."}},"i":0}}]}'>Hardware Type (HTYPE): 16 bits
- This field specifies the network link protocol type. In this example, a value of 0x0800. The permitted PTYPE values share a numbering space with those for EtherType.
- Protocol Length (PLEN): 8 bits
- Length (in octets) of internetwork addresses. The internetwork protocol is specified in PTYPE. In this example: IPv4 address length is Sender Hardware Address (SHA): 48 bits
- Media address of the sender. In an ARP request, this field is used to indicate the address of the host sending the request. In an ARP reply, this field is used to indicate the address of the host that the request was looking for.
- Target Protocol Address (TPA): 32 bits
- Internetwork address of the intended receiver.
ARP parameter values have been standardized and are maintained by the Internet Assigned Numbers Authority (IANA).
The EtherType for ARP is RFC 1122 also discusses ARP in its link layer section.
Richard Stevens places ARP in the OSI's data link layer while newer editions associate it with the network layer or introduce an intermediate OSI layer 2.5.
Two computers, A and B, are connected to the same local area network with no intervening gateway or router. A has a packet to send to IP address FF:FF:FF:FF:FF:FF and requesting response from the node with IP address RFC 826 – "An Ethernet Address Resolution Protocol," Internet Standard 37.
RFC 5227 – "IPv4 Address Conflict Detection," Proposed Standard.
- Arping – Software utility for discovery of hosts on a computer network
- Arptables – Network administrator's tool
- Arpwatch – Computer networking software tool
- Bonjour Sleep Proxy – Open source component of zero configuration networking
- Cisco HDLC – Extension to the High-Level Data Link Control (HDLC) network protocol
- Neighbor Discovery Protocol – Protocol in the Internet protocol suite used with IPv6