| RFC 8620 and RFC 9007.
Several further JMAP extensions have been published as proposed standards: blob management (RFC 9610), Sharing (RFC 9749). Only the JMAP calendar standards are left as drafts, namely JMAP Calendars and the JSCalendar 2.0 format. The working group originally set milestones for some of these to be finalised by the end of 2020.
Servers:
- Since its release of version 3.6.0 in 2021, Apache Software Foundation’s free mail-server Apache James has included support for the JMAP RFCs.
- Cyrus IMAP provisionally supports all non-draft JMAP protocol standards, when built with this functionality.
- Stalwart Mail Server has supports JMAP Core, JMAP Mail and JMAP over WebSocket at IMAP4rev2.
- The OpenPaas collaboration platform implements among email, though through James.
- inbuxa is a free (AGPL-3.0) mail and collaboration server written in Rust, supporting JMAP alongside IMAP, POP3 and SMTP.
Clients:
- Mailtemi is a JMAP/MS Graph/IMAP email app for iOS and Android. It supports calendars, contacts, and multiple email accounts.
- Ltt.rs is a proof of concept email client for Android that supports only JMAP.
- Twake Mail is an open source app client for iOS and Android developed by Linagora.
- aerc is a terminal-based email client, which added support for JMAP in version 0.16
- Bulwarkmail is a free (AGPL-3.0) JMAP-native webmail client for Stalwart Mail Server, integrating email, calendar, contacts, and file storage.
- Sterna Mail is an open-source JMAP client for Android.
- ihasmail is a free (AGPL-3.0) JMAP webmail client.
|